Received a mail non-delivery report : “Client host rejected: cannot find your reverse hostname”


If you receive the following non-delivery report while sending a mail:

“Client host rejected: cannot find your reverse hostname”

first check whether ‘PTR’ record is set for the IP address from which you are trying to send mails (IP address of MX server), If not, create a ‘PTR’ record using the steps mentioned below.

1. Login to control panel.
2. Select 'All my Domains' from the subscription drop-down menu at the top of the control panel.
3. Click on 'Reverse DNS' tab.
4. Click on 'New Record'.
5. Select the required name from the 'Name' drop-down menu.
6. Provide the hostname of the server in the 'value' field.
7. Click on 'Save'.

Some cases, you may see a multiple ‘PTR’ record for the same IP address. Please note that, you can have multiple PTR records for a given IP address. However, it is not recommended to have multiple ‘PTR’ records for a given IP address because when a request is made for the PTR record of an IP address, the requester sees a stack of records, but only reads the first one. The rest are assumed to be supporting records (NS records, etc.). In some cases, this may not work properly as the result is a randomly-chosen record from the set of PTR records which may not match with the exact name.

This will result in the above mentioned error “Client host rejected: cannot find your reverse hostname”.

Cause
========
When we point multiple domains to a dedicated IP address, it will create a ‘PTR’ record automatically for each domain. This is the reason for multiple ‘PTR’ records for the a single IP address. This may cause confusion to the receiving server.

Fix
=====
Remove all the ‘PTR’ records and create a ‘PTR’ for the hostname of the server. In order to remove current 'PTR' records, follow the below steps.

1. Login to control panel.
2. Select 'All my Domains' from the subscription drop-down menu at the top of the control panel.
3. Click on 'Reverse DNS' tab.
5. Select all listed 'PTR' records and click on 'Delete'.

After deleting the current 'PTR' records, create a new 'PTR'  for hostname of the server using the steps mentioned above.

Last update:
2015-02-04 18:14
Author:
Sherin George
Revision:
1.1
Average rating:0 (0 Votes)

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